XAMPP e Windows 7

Xamp screenshot

Lo sanno anche i muri, è uscito Windows 7, bella novità! Ma questo neonato di mamma microsoft infastidirà noi sviluppatori WAMP come il suo predecessore?
La risposta: No

Sembra incredibile ma XAMP 1.7.2 su windows 7 a 64 bit funziona senza problemi, ametto che io sono un fanatico della versione lite di XAMPP ma sono molto confidente che tutto funzioni anche nella full!

Qui sotto uno bello screenshoot cosi da dimostrare che tutto gira!

La Strada di Ubuntu

Share this post

Comments (19)

  • anon

    Funziona anche la versione 1.7.1 di XAMPP su windows 7 a 64bit?

    Grazie

    Nov 23, 2009
  • anon

    Sinceramente ho provato la 1.7.1 solo su Vista a x64 ma se "regge" i 64 bit di Vista sono confidente che regga i 64 bit di Windows 7.

    Nov 24, 2009
  • anon

    Ok grazie!! Dopo che lo provo ti faccio sapere

    Nov 24, 2009
  • anon

    Ci conto!

    Nov 25, 2009
  • anon

    Ho installato xampp 1.7.1 su wundows 7 a 64 bit, e funziona senza nessun problema, ovviamente va avviato con privilegi di amministratore

    Nov 27, 2009
  • anon

    confermo anche per me la standalone funziona su win764bit

    May 17, 2011
  • anon

    Ho gia provato tutto di tutto! Non ho skype, non ho IIS, non ho firewalls e disattivo anche l-antivirus, eseguo tutto come amministratore, in modalita' compatibilita' con XP, ho gia provato a cambiare la porta 80 in 81, 8080, e molte altre... insomma: sono alla frutta!
    Quando faccio start server mi continua a dire "no listening sockets available'' e mi stoppa in automatico sia Apache che Mysql. Mi [ sembrato che nessuno ha avuto tanta sfiga come me... tutti risolvono prima o poi ma io ci sto sbattendo la faccia da oltre 3 giorni! Aiutooooooooooo!

    Feb 11, 2012
  • anon

    Devi verificare che la porta non sia già usata prova ad aprire un terminal da start esegui cmd poi dentro al terminale fai netstat -a e vedi le righe che finiscono con listening

    esempio :

    TCP 127.0.0.1:5939 baby:0 LISTENING
    TCP 127.0.0.1:9089 baby:0 LISTENING
    TCP 127.0.0.1:9421 baby:0 LISTENING
    TCP 127.0.0.1:9422 baby:0 LISTENING
    TCP 127.0.0.1:9423 baby:0 LISTENING
    TCP 127.0.0.1:62514 baby:0 LISTENING

    Non devi avere nulla che finisce con :80 o :443
    Nel caso non funzionasse prova a lanciare il batch di start di apache direttamente in un terminal dovresti riuscire a vedere l'errore in maniera più chiara.

    Apr 11, 2012
  • anon

    Ciao!
    Anch'io l'ho installato e con i dovuti accorgimenti e liberando le porte pare funzionare tutto.
    Però non mi funziona il mod_rewrite! Nell'ultima versione è già abilitato, tutti gli accorgimenti suggeriti qua è la sono già applicati, ma non funziona!
    Ha a che fare con windows 7? Qualcuno ne sa qualcosa?

    Oct 01, 2010
  • anon

    io ho sbloccato la porta 80, ho consentito l'accesso dal mio firewall, ho spuntato l'opzione di skype per liberare la porta 80 ma apache ancora non vuole partire (windows 7 ultimate 64bit). Mi risponde continuamente con busy.

    Jan 08, 2011
  • anon

    Ciao,

    Ormai uso abitualmente Xamp sotto windows 7 a 64 bit e ti posso assicurare che va egregiamente, se hai già tolto skype dalla porta 80 verifica che non ci sia qualcos'altro sulla stessa porta!

    Jan 10, 2011
  • anon

    ma è meglio installarlo sotto C , sotto programmi o sotto programmi(x86)????

    Mar 14, 2011
  • anon

    Installa xamp dove vuoi, non ci sono posti migliori e peggiori!

    Mar 14, 2011
  • anon
    Anonymous (not verified)

    sto cercando in tutti i tipi e int tutti i programmi ma nulla >:<'' questo cavolo di apache non parte ora chiamiamo Aldo Busy e gli facciamo risolvere a lui sto busy xD

    Aug 10, 2011
  • anon
    Anonymous (not verified)

    La soluzione su Windows 7 è non installare la versione Installer, ma quella ZIP e poi ricordarsi di lanciare il file "setup_xampp.bat".

    Aug 30, 2011
  • anon

    grazie ho risolto seguendo il tuo consiglio

    Oct 01, 2012
  • anon

    Ho appena scaricato xampp e non riesco a spuntare la casella apache per aggiungere l applicazione a servizi....
    Pero quando clicco su start mi pare che funzioni....che faccio?

    Feb 09, 2014
  • anon

    Ho appena scaricato xampp e non riesco a spuntare la casella apache per aggiungere l applicazione a servizi....
    Pero quando clicco su start mi pare che funzioni....che faccio?

    Feb 09, 2014